Quality RTOS & Embedded Software

 Real time embedded FreeRTOS RSS feed 
Quick Start Supported MCUs PDF Books Trace Tools Ecosystem


Loading

FreeRTOS Simulator - Eclipse+MingW - Crashes

Posted by pmtwiss on January 7, 2019

Hi Everyone,

New to SourceForge, and new to FreeRTOS. I am trying to use the MingW simulator provided by the RTOS zip (under demo). Tried to run the simulation of blinky, the more basic demo, (main_blinky.c), by setting:

define mainCREATESIMPLEBLINKYDEMOONLY 1

Not sure why that text paste so huge ... sorry.

Anyways, I tried on 2 different machines, and when I only, simply set this definition to 1, it crash. I'm doing nothing else.

NOTE: When this bit is szet to 0 (Test Demo), it runs perfectly.

Is there something I am missing?

System Info: - Windows 10 64 (fully updated) - Eclipse, build 2019-12 - FreeRTOS v10.1.1 - Eclipse set up with MingW - I can write C-code and compile and run just fine (not system related)

Any help would be great, I'd like to start with the blinky as the test version is crazy as hell and I am not ready for that.

[SEE ATTACHED IMAGE] - one one machine, the other just totally crash eclipse

Thanks, -P


FreeRTOS Simulator - Eclipse+MingW - Crashes

Posted by rtel on January 7, 2019

Apologies for this. It is because the trace recorder library is only initialized if mainCREATESIMPLEBLINKYDEMOONLY is set to 0, but still used even when it is set to 1. I have fixed this here: https://sourceforge.net/p/freertos/code/HEAD/tree/trunk/FreeRTOS/Demo/WIN32-MingW/main.c#l145 by moving the trace recorder library initialisation up so it is initialized no matter the mainCREATESIMPLEBLINKYDEMOONLY setting.

Attachments

blinky.png (8255 bytes)

FreeRTOS Simulator - Eclipse+MingW - Crashes

Posted by pmtwiss on January 7, 2019

Hi Richard,

Thanks for your fast response my friend! In the comments it states the tracer is optional, but looks like it's required. I'll read on the tracer, there is a link. I love how well this code is commented.

Thanks again

Attachments

blinky.png (8255 bytes)

FreeRTOS Simulator - Eclipse+MingW - Crashes

Posted by pmtwiss on January 7, 2019

I made the change and it fixed the issue.

[RESOLVED]

(I don't see the resolved/solutions button here}

Attachments

blinky.png (8255 bytes)


[ Back to the top ]    [ About FreeRTOS ]    [ Privacy ]    [ Sitemap ]    [ ]


Copyright (C) Amazon Web Services, Inc. or its affiliates. All rights reserved.

Latest News

FreeRTOS v10.2.0 is available for immediate download. MIT licensed, and including RISC-V and ARMv8-M (Cortex-M33) demos.

NXP tweet showing LPC5500 (ARMv8-M Cortex-M33) running FreeRTOS.

View a recording of the "OTA Update Security and Reliability" webinar, presented by TI and AWS.


Careers

FreeRTOS and other embedded software careers at AWS.



FreeRTOS Partners

ARM Connected RTOS partner for all ARM microcontroller cores

Cadence Tensilica Cortes

Espressif ESP32

IAR Partner

Microchip Premier RTOS Partner

RTOS partner of NXP for all NXP ARM microcontrollers

Mediatek

Renesas

RISC-V

SiFIve RISC-V

STMicro RTOS partner supporting ARM7, ARM Cortex-M3, ARM Cortex-M4 and ARM Cortex-M0

Texas Instruments MCU Developer Network RTOS partner for ARM and MSP430 microcontrollers

OpenRTOS and SafeRTOS

Xilinx Microblaze and Zynq partner